Archive

Archive for January, 2015

Run iMovie HD (and maybe other older applications) in Yosemite (and now El Capitan)

January 23rd, 2015 135 comments

I was disappointed to see that I could no longer run iMovie HD (available here) after upgrading to Mac OS X 10.10 Yosemite. The Finder gave me an error saying, You can’t use this version of the application “iMovie HD” with this version of OS X. You have “iMovie HD” 6.0.3. I was delighted to discover a workaround that works, well, for now. Here’s how.

UPDATE, Sept 2015: Looks like this trick works in El Capitan too.

UPDATE, Nov 2015: Skip straight to Rolando’s comment below for the best solution yet, or download the already-modified iMovie from this this related post right here on this blog.

iMovie HD error message on Yosemite
Read more…